Debian / Ubuntu system prerequisites

Debian or Ubuntu systems require the following packages:

apt-get install \
    bison \
    ca-certificates \
    cmake \
    curl \
    default-jre \
    flex \
    gettext \
    git \
    libbz2-dev \
    libcurl4-openssl-dev \
    libfontconfig1 \
    libglib2.0-dev \
    libncurses5-dev \
    libreadline6-dev \
    libx11-dev \
    libxrender1 \
    libxt-dev \
    m4 \
    make \
    perl-modules \

Prefix the apt-get command with sudo if necessary.


If you get an error, run:

apt-get update --fix-missing

Then re-run the apt-get install command, above.


New since 17.0: The gcc compiler to be used shall fully support C++ 14. The gcc version used to compile the LSST Science Pipelines shall be at least gcc 6.1.

Additional installation steps for Ubuntu 16

If you are deploying lsst_distrib in an Ubuntu 16.04 operating system, the gcc compiler version installed using the above steps is the 5.4. In order to get a gcc version compatible with C++ 14, following steps have to be completed in addition at the above ones.

sudo apt-get update
sudo apt-get install build-essential software-properties-common
sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update
sudo apt-get install gcc-6 g++-6
sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-6 60 --slave /usr/bin/g++ g++ /usr/bin/g++-6


The command, above, modifies system-wide configuration and will impact other users on the machine.